# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(readWriteDataGroup=")(?!Everyone")[^"]*(")/$1X$2/gm;t' <<< "readWriteDataGroup=\"Everyone\"
readWriteDataGroup=\"E_MOD_WSP_64\"
readWriteDataGroup=\"Everyone\"
readWriteDataGroup=\"E_MOD_ABC_01\"
readWriteDataGroup=\"Everyone\"
"