import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(readWriteDataGroup=\")(?!Everyone\")[^\"]*(\")";
final String string = "readWriteDataGroup=\"Everyone\"\n"
+ "readWriteDataGroup=\"E_MOD_WSP_64\"\n"
+ "readWriteDataGroup=\"Everyone\"\n"
+ "readWriteDataGroup=\"E_MOD_ABC_01\"\n"
+ "readWriteDataGroup=\"Everyone\"\n";
final String subst = "$1X$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}