import Foundation
let pattern = #"(readWriteDataGroup=")(?!Everyone")[^"]*(")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_WSP_64"
readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_ABC_01"
readWriteDataGroup="Everyone"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1X$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)