const regex = /(readWriteDataGroup=")(?!Everyone")[^"]*(")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(readWriteDataGroup=")(?!Everyone")[^"]*(")', 'gm')
const str = `readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_WSP_64"
readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_ABC_01"
readWriteDataGroup="Everyone"
`;
const subst = `$1X$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);