re = /(readWriteDataGroup=")(?!Everyone")[^"]*(")/m
str = 'readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_WSP_64"
readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_ABC_01"
readWriteDataGroup="Everyone"
'
subst = '$1X$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result