using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(readWriteDataGroup="")(?!Everyone"")[^""]*("")";
string substitution = @"$1X$2";
string input = @"readWriteDataGroup=""Everyone""
readWriteDataGroup=""E_MOD_WSP_64""
readWriteDataGroup=""Everyone""
readWriteDataGroup=""E_MOD_ABC_01""
readWriteDataGroup=""Everyone""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}