$re = '/(readWriteDataGroup=")(?!Everyone")[^"]*(")/m';
$str = 'readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_WSP_64"
readWriteDataGroup="Everyone"
readWriteDataGroup="E_MOD_ABC_01"
readWriteDataGroup="Everyone"
';
$subst = "$1X$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;