package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)`)
var str = `FPN 0085110A
FPN 0091010Y
FPN 0095100J
FPN 0095130B
FPN 0097660F
AGEBAND10YR 0-9
AGEBAND10YR 10-19
AGEBAND10YR 20-29
AGEBAND10YR 30-39
AGEBAND10YR 40-49
AGEBAND10YR 50-59
AGEBAND10YR 60-69
AGEBAND10YR 70-79
DRGGrpV6X 801A
DRGGrpV6X 801B
DRGGrpV6X A09B
DRGGrpV6X A11A
DRGGrpV6X A11B
DRGGrpV6X A12Z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}