import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{1}\\d{2}[A-Z]{1}$|\\d{1}\\d{2}[A-Z]{1}$|\\d{7}[A-Z]{1}$|\\d{1,2}\\-\\d{1,2}$)";
final String string = "FPN 0085110A\n"
+ "FPN 0091010Y\n"
+ "FPN 0095100J\n"
+ "FPN 0095130B\n"
+ "FPN 0097660F\n"
+ "AGEBAND10YR 0-9\n"
+ "AGEBAND10YR 10-19\n"
+ "AGEBAND10YR 20-29\n"
+ "AGEBAND10YR 30-39\n"
+ "AGEBAND10YR 40-49\n"
+ "AGEBAND10YR 50-59\n"
+ "AGEBAND10YR 60-69\n"
+ "AGEBAND10YR 70-79\n"
+ "DRGGrpV6X 801A\n"
+ "DRGGrpV6X 801B\n"
+ "DRGGrpV6X A09B\n"
+ "DRGGrpV6X A11A\n"
+ "DRGGrpV6X A11B\n"
+ "DRGGrpV6X A12Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}