import re
regex = re.compile(r"([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)", flags=re.MULTILINE)
test_str = ("FPN 0085110A\n"
"FPN 0091010Y\n"
"FPN 0095100J\n"
"FPN 0095130B\n"
"FPN 0097660F\n"
"AGEBAND10YR 0-9\n"
"AGEBAND10YR 10-19\n"
"AGEBAND10YR 20-29\n"
"AGEBAND10YR 30-39\n"
"AGEBAND10YR 40-49\n"
"AGEBAND10YR 50-59\n"
"AGEBAND10YR 60-69\n"
"AGEBAND10YR 70-79\n"
"DRGGrpV6X 801A\n"
"DRGGrpV6X 801B\n"
"DRGGrpV6X A09B\n"
"DRGGrpV6X A11A\n"
"DRGGrpV6X A11B\n"
"DRGGrpV6X A12Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")