import Foundation
let pattern = #"([A-Z]{1}\d{2}[A-Z]{1}$|\d{1}\d{2}[A-Z]{1}$|\d{7}[A-Z]{1}$|\d{1,2}\-\d{1,2}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FPN 0085110A
FPN 0091010Y
FPN 0095100J
FPN 0095130B
FPN 0097660F
AGEBAND10YR 0-9
AGEBAND10YR 10-19
AGEBAND10YR 20-29
AGEBAND10YR 30-39
AGEBAND10YR 40-49
AGEBAND10YR 50-59
AGEBAND10YR 60-69
AGEBAND10YR 70-79
DRGGrpV6X 801A
DRGGrpV6X 801B
DRGGrpV6X A09B
DRGGrpV6X A11A
DRGGrpV6X A11B
DRGGrpV6X A12Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)