# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/ice\\/flag\\/(?:[^?#\n]*\\/)?)[^\\/#?\n]+/$1redacted/gm;t' <<< "https://test.com/plants/ice/flag/237468372912873
https://test.com/plants/extra/ice/flag/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873
https://test.com/plants/ice/flag/extra/extra/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash
https://test.com/plants/not_ice/flag/237468372912873"