re = /(\/ice\/flag\/(?:[^?#\n]*\/)?)[^\/#?\n]+/m
str = 'https://test.com/plants/ice/flag/237468372912873
https://test.com/plants/extra/ice/flag/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873
https://test.com/plants/ice/flag/extra/extra/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash
https://test.com/plants/not_ice/flag/237468372912873'
subst = '$1redacted'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result