const regex = /(\/ice\/flag\/(?:[^?#\n]*\/)?)[^\/#?\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/ice\\\/flag\\\/(?:[^?#\\n]*\\\/)?)[^\\\/#?\\n]+', 'gm')
const str = `https://test.com/plants/ice/flag/237468372912873
https://test.com/plants/extra/ice/flag/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873
https://test.com/plants/ice/flag/extra/extra/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash
https://test.com/plants/not_ice/flag/237468372912873`;
const subst = `$1redacted`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);