import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/ice\\/flag\\/(?:[^?#\\n]*\\/)?)[^\\/#?\\n]+";
final String string = "https://test.com/plants/ice/flag/237468372912873\n"
+ "https://test.com/plants/extra/ice/flag/237468372912873\n"
+ "https://test.com/plants/ice/flag/extra/237468372912873\n"
+ "https://test.com/plants/ice/flag/extra/extra/237468372912873\n"
+ "https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash\n"
+ "https://test.com/plants/not_ice/flag/237468372912873";
final String subst = "$1redacted";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}