// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/ice\/flag\/(?:[^?#\n]*\/)?)[^\/#?\n]+").unwrap();
let string = "https://test.com/plants/ice/flag/237468372912873
https://test.com/plants/extra/ice/flag/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873
https://test.com/plants/ice/flag/extra/extra/237468372912873
https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash
https://test.com/plants/not_ice/flag/237468372912873";
let substitution = "$1redacted";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}