#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/ice\/flag\/(?:[^?#\n]*\/)?)[^\/#?\n]+"
Local $sString = "https://test.com/plants/ice/flag/237468372912873" & @CRLF & _
"https://test.com/plants/extra/ice/flag/237468372912873" & @CRLF & _
"https://test.com/plants/ice/flag/extra/237468372912873" & @CRLF & _
"https://test.com/plants/ice/flag/extra/extra/237468372912873" & @CRLF & _
"https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash" & @CRLF & _
"https://test.com/plants/not_ice/flag/237468372912873"
Local $sSubst = "$1redacted"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)