# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/ice\/flag\/(?:[^?#\n]*\/)?)[^\/#?\n]+"
test_str = ("https://test.com/plants/ice/flag/237468372912873\n"
"https://test.com/plants/extra/ice/flag/237468372912873\n"
"https://test.com/plants/ice/flag/extra/237468372912873\n"
"https://test.com/plants/ice/flag/extra/extra/237468372912873\n"
"https://test.com/plants/ice/flag/extra/237468372912873?paramOne=1¶mTwo=2/12#someHash\n"
"https://test.com/plants/not_ice/flag/237468372912873")
subst = "$1redacted"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.