#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$"
Local $sString = "f 1 2 3" & @CRLF & _
"f 1/ 2/ 3/" & @CRLF & _
"f 1// 2// 3//" & @CRLF & _
"f 1/1 2/2 3/3" & @CRLF & _
"f 1/1/ 2/2/ 3/3/" & @CRLF & _
"f 1//1 2//2 3//3" & @CRLF & _
"" & @CRLF & _
"f /1/ /2/ /3/" & @CRLF & _
"f 1/1/1 2/2/2 3//3" & @CRLF & _
"f 1/1 2/2 3/3 4/4" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$" & @CRLF & _
"[18:08, 20/11/2019] Jose Luis Uni" & @CRLF & _
"^f(([ ]\d+(\/{0,2}\d+))+)$" & @CRLF & _
"[18:30, 20/11/2019] Jose Luis Uni: " & @CRLF & _
"^f(([ ](\d+)(\/{0,2}\d+))+)$" & @CRLF & _
"" & @CRLF & _
"^f(([ ](\d+)(\/{0,2}\d*))+)$" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")