import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})$";
final String string = "f 1 2 3\n"
+ "f 1/ 2/ 3/\n"
+ "f 1// 2// 3//\n"
+ "f 1/1 2/2 3/3\n"
+ "f 1/1/ 2/2/ 3/3/\n"
+ "f 1//1 2//2 3//3\n\n"
+ "f /1/ /2/ /3/\n"
+ "f 1/1/1 2/2/2 3//3\n"
+ "f 1/1 2/2 3/3 4/4\n\n\n"
+ "^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})$\n"
+ "[18:08, 20/11/2019] Jose Luis Uni\n"
+ "^f(([ ]\\d+(\\/{0,2}\\d+))+)$\n"
+ "[18:30, 20/11/2019] Jose Luis Uni: \n"
+ "^f(([ ](\\d+)(\\/{0,2}\\d+))+)$\n\n"
+ "^f(([ ](\\d+)(\\/{0,2}\\d*))+)$\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}