import re
regex = re.compile(r"^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$", flags=re.MULTILINE)
test_str = ("f 1 2 3\n"
"f 1/ 2/ 3/\n"
"f 1// 2// 3//\n"
"f 1/1 2/2 3/3\n"
"f 1/1/ 2/2/ 3/3/\n"
"f 1//1 2//2 3//3\n\n"
"f /1/ /2/ /3/\n"
"f 1/1/1 2/2/2 3//3\n"
"f 1/1 2/2 3/3 4/4\n\n\n"
"^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})$\n"
"[18:08, 20/11/2019] Jose Luis Uni\n"
"^f(([ ]\\d+(\\/{0,2}\\d+))+)$\n"
"[18:30, 20/11/2019] Jose Luis Uni: \n"
"^f(([ ](\\d+)(\\/{0,2}\\d+))+)$\n\n"
"^f(([ ](\\d+)(\\/{0,2}\\d*))+)$\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")