use strict;
my $str = 'f 1 2 3
f 1/ 2/ 3/
f 1// 2// 3//
f 1/1 2/2 3/3
f 1/1/ 2/2/ 3/3/
f 1//1 2//2 3//3
f /1/ /2/ /3/
f 1/1/1 2/2/2 3//3
f 1/1 2/2 3/3 4/4
^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})$
[18:08, 20/11/2019] Jose Luis Uni
^f(([ ]\\d+(\\/{0,2}\\d+))+)$
[18:30, 20/11/2019] Jose Luis Uni:
^f(([ ](\\d+)(\\/{0,2}\\d+))+)$
^f(([ ](\\d+)(\\/{0,2}\\d*))+)$
';
my $regex = qr/^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}