// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$").unwrap();
let string = "f 1 2 3
f 1/ 2/ 3/
f 1// 2// 3//
f 1/1 2/2 3/3
f 1/1/ 2/2/ 3/3/
f 1//1 2//2 3//3
f /1/ /2/ /3/
f 1/1/1 2/2/2 3//3
f 1/1 2/2 3/3 4/4
^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})$
[18:08, 20/11/2019] Jose Luis Uni
^f(([ ]\\d+(\\/{0,2}\\d+))+)$
[18:30, 20/11/2019] Jose Luis Uni:
^f(([ ](\\d+)(\\/{0,2}\\d+))+)$
^f(([ ](\\d+)(\\/{0,2}\\d*))+)$
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}