package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$`)
var str = `f 1 2 3
f 1/ 2/ 3/
f 1// 2// 3//
f 1/1 2/2 3/3
f 1/1/ 2/2/ 3/3/
f 1//1 2//2 3//3
f /1/ /2/ /3/
f 1/1/1 2/2/2 3//3
f 1/1 2/2 3/3 4/4
^f(([ ]\d{1,2}(\/{0,2}\d{0,1})\/{0,1}){0,3})$
[18:08, 20/11/2019] Jose Luis Uni
^f(([ ]\d+(\/{0,2}\d+))+)$
[18:30, 20/11/2019] Jose Luis Uni:
^f(([ ](\d+)(\/{0,2}\d+))+)$
^f(([ ](\d+)(\/{0,2}\d*))+)$
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}