#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)"
Local $sString = "X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3 " & @CRLF & _
" Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")