re = /(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)/
str = 'X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3
Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end