import Foundation
let pattern = #"(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3
Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)