import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(X|Y|Z|A3=|B3=|C3=)(\\-?\\d+(?:\\.\\d+)?)";
final String string = "X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3 \n"
+ " Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}