use strict;
my $str = 'X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3
Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3';
my $regex = qr/(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}