package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)`)
var str = `X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3
Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}