// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(X|Y|Z|A3=|B3=|C3=)(\-?\d+(?:\.\d+)?)").unwrap();
let string = "X2 G1 X-387.7 A3=-1.0 B3=0.0 C3=0.0 F=R3
Y1.824 Z264.663 A3=-1.0 C3=0.0 YY123.4 3X213.3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}