#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$"
Local $sString = " %import Regen.Core.Tests.ImportMe as reg" & @CRLF & _
" %import Regen.Core.Tests.ImportMe" & @CRLF & _
" %import Regen.Core.Tests.ImportMe" & @CRLF & _
" %import Regen.Core.Tests.ImportMe as reg" & @CRLF & _
" %import Regen.Core.Tests.ImportMe" & @CRLF & _
" %(magic(1,1))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")