package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$`)
var str = ` %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}