using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$";
string input = @" %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}