const regex = /%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%import\\s ([\\s\\S]+?) (?:\\sas\\s([\\s\\S]+?))?$', 'gm')
const str = ` %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}