re = /%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$/mx
str = ' %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end