// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$").unwrap();
let string = " %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}