$re = '/%import\s ([\s\S]+?) (?:\sas\s([\s\S]+?))?$/mx';
$str = ' %import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe
%import Regen.Core.Tests.ImportMe as reg
%import Regen.Core.Tests.ImportMe
%(magic(1,1))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);