package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))`)
var str = `Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name. Some more text.
©2025 Some Super Long Company Name. Some more text.
©2025 by Some Super Long Company Name. Some more text.
©2025 by, Some Super Long Company Name. Some more text.
Copyright 2025 Some Super Long Company Name. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name Some more text
Built by Clomp! Visit https://www.clomp.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}