// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))").unwrap();
let string = "Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name. Some more text.
©2025 Some Super Long Company Name. Some more text.
©2025 by Some Super Long Company Name. Some more text.
©2025 by, Some Super Long Company Name. Some more text.
Copyright 2025 Some Super Long Company Name. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name Some more text
Built by Clomp! Visit https://www.clomp.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}