$re = '/(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))/m';
$str = 'Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name. Some more text.
©2025 Some Super Long Company Name. Some more text.
©2025 by Some Super Long Company Name. Some more text.
©2025 by, Some Super Long Company Name. Some more text.
Copyright 2025 Some Super Long Company Name. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name Some more text
Built by Clomp! Visit https://www.clomp.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);