# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))"
test_str = ("Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.\n"
"Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.\n"
"Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.\n"
"Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.\n"
"© 2025 Some Super Long Company Name All Rights Reserved Some more text.\n"
"© 2025 Some Super Long Company Name. Some more text.\n"
"©2025 Some Super Long Company Name. Some more text.\n"
"©2025 by Some Super Long Company Name. Some more text.\n"
"©2025 by, Some Super Long Company Name. Some more text.\n"
"Copyright 2025 Some Super Long Company Name. Some more text.\n"
"Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.\n"
"Copyright © 2000..2025 by, Some Super Long Company Name Some more text\n"
"Built by Clomp! Visit https://www.clomp.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.