use strict;
my $str = 'Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name. Some more text.
©2025 Some Super Long Company Name. Some more text.
©2025 by Some Super Long Company Name. Some more text.
©2025 by, Some Super Long Company Name. Some more text.
Copyright 2025 Some Super Long Company Name. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name Some more text
Built by Clomp! Visit https://www.clomp.com';
my $regex = qr/(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}