const regex = /(Copyright\s)?(©|\(c\)|©|©|©)?\s?((19|20)\d{2})(\.\.(19|20)\d{2})?(\s(by))?(,)?(.+All Rights Reserved\.|.+All Rights Reserved|([\w\s]+)(\.)|(.{29}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Copyright\\s)?(©|\\(c\\)|©|©|©)?\\s?((19|20)\\d{2})(\\.\\.(19|20)\\d{2})?(\\s(by))?(,)?(.+All Rights Reserved\\.|.+All Rights Reserved|([\\w\\s]+)(\\.)|(.{29}))', 'gm')
const str = `Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.
Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name All Rights Reserved Some more text.
© 2025 Some Super Long Company Name. Some more text.
©2025 Some Super Long Company Name. Some more text.
©2025 by Some Super Long Company Name. Some more text.
©2025 by, Some Super Long Company Name. Some more text.
Copyright 2025 Some Super Long Company Name. Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.
Copyright © 2000..2025 by, Some Super Long Company Name Some more text
Built by Clomp! Visit https://www.clomp.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}