import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Copyright\\s)?(©|\\(c\\)|©|©|©)?\\s?((19|20)\\d{2})(\\.\\.(19|20)\\d{2})?(\\s(by))?(,)?(.+All Rights Reserved\\.|.+All Rights Reserved|([\\w\\s]+)(\\.)|(.{29}))";
final String string = "Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text.\n"
+ "Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved Some more text.\n"
+ "Copyright © 2025 Some Super Long Company Name All Rights Reserved. Some more text.\n"
+ "Copyright © 2025 Some Super Long Company Name All Rights Reserved Some more text.\n"
+ "© 2025 Some Super Long Company Name All Rights Reserved Some more text.\n"
+ "© 2025 Some Super Long Company Name. Some more text.\n"
+ "©2025 Some Super Long Company Name. Some more text.\n"
+ "©2025 by Some Super Long Company Name. Some more text.\n"
+ "©2025 by, Some Super Long Company Name. Some more text.\n"
+ "Copyright 2025 Some Super Long Company Name. Some more text.\n"
+ "Copyright © 2000..2025 by, Some Super Long Company Name. All Rights Reserved. Some more text. Copyright © 2025 Some Company All Rights Reserved Some more text.\n"
+ "Copyright © 2000..2025 by, Some Super Long Company Name Some more text\n"
+ "Built by Clomp! Visit https://www.clomp.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}