using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:";
string input = @"Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}