import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Client Name: (?<client_name>[\\w\\W]+?)\\s+Client Question: (?<client_question>[\\w\\W]+?)\\s+Additional Info: (?<additional_info>[\\w\\W]+?)\\s+Attachments:";
final String string = "Client Name: Client\n"
+ "Client Question: Question\n"
+ "Additional Info: Additional INfo\n"
+ "Attachments:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}