const regex = /Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Client Name: (?<client_name>[\\w\\W]+?)\\s+Client Question: (?<client_question>[\\w\\W]+?)\\s+Additional Info: (?<additional_info>[\\w\\W]+?)\\s+Attachments:', 'g')
const str = `Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}