re = /Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:/
str = 'Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end