// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:").unwrap();
let string = "Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}